How to reset your point of origin

All 3D applications will allow you to reset a finished model to the 0,0,0 Point of Origin.

 

3dsMax

  1. Select your model.
  2. From the menu bar select Edit -> Transform Toolbox
  3. Within the Align Pivot set of controls, ensure Min is active and then hit the Z button to force the pivot to the base of the group bounding box.
    TransformToolbox_Dialog.jpg

    This will move your pivot to the base of your model. 

  4. Press the W-key to enter move mode, then hit the F12 button to bring up the Transform Type-in dialog.

  5. Within the Absolute:World side of the dialog, reset the X, Y and Z position to 0.0.
    MoveTTI_Dialog.jpg
    At this point, if you want to center the pivot again, under Align Pivot in the Transform Toolbox, click the Center button to move your pivot back to the center of your object.
  1. If the model consists of multiple elements (like a car or helmet), be sure to Group everything first from the Group -> Group menu and name it appropriately.
    Group_GroupMenu.jpg

  2. Open the group using the Group -> Open menu, then select the group object node directly (it’ll show up in pink in the main UI by default).
    Group_OpenMenu.jpg
  3. Next, go to the Hierarchy command panel and activate Affect Pivot Only for the group node. The pivot point should show up in the center of the bounding box for the model.
    Hierarchy_APO.jpg
  4. From the main 3ds Max menu, go to Edit -> Transform Toolbox to open the small floating dialog.
  5. Within the Align Pivot set of controls, ensure Min is active and then hit the Z button to force the pivot to the base of the group bounding box.
    TransformToolbox_Dialog.jpg
    Now that your group’s pivot point is properly placed, you can move the object to the origin above the ground plane.
  6. Deactivate the Affect Pivot Only button in the Hierarchy command panel.
  7. Press the W-key to enter move mode, then hit the F12 button to bring up the Transform Type-in dialog.
  8. Within the Absolute:World side of the dialog, reset the X, Y and Z position to 0.0.MoveTTI_Dialog.jpg
    At this point, your model should be centered on the origin and sitting on the ground plane.

 

 

Maya

Centering your pivot and ensuring it’s at the base of your model in Maya is a multi-step process. You first center the pivot, then determine the point on the model at which is the lowest on the Y-axis so that it sits on the ground plane properly. Once the pivot is positioned properly, then you can snap it to the origin and freeze your transforms.
Centering the Pivot:
  1. Select your model. If the model consists of multiple elements, use the Edit -> Group command to group everything, then ensure the Group node is selected in the Outliner.
  2. Select Modify from the top menu and select Center Pivot to relocate the pivot point to the center of the model.
    Maya_CenterPivotMenu2.jpg
    As you might expect, this will center the pivot to the center of the entire model, not just one element within it.

Moving the Pivot:

Now that you have the pivot centered, you’ll move it down on the Y-axis so that the model will sit properly on the ground plane. That means determining the lowest point on your geometry. In many cases, that won’t be simple to see, so a foolproof way is to create a temporary bounding box around your model and snap the pivot of your model to the bottom of that box.

  1. With the model selected, go to Modify -> Convert -> Geometry to Bounding Box [Options], and within the floating dialog ensure that One bounding box is selected and the Keep Original checkbox is active. Then hit Convert.
    Convert_BBox_Dialog.jpg
    This will create a bounding box that should surround your entire model. Now you can snap your pivot on the Y-axis to match the base of the new box.
  2. Select your model.
  3. Hit the Insert or D-key to go into Pivot mode on the model.
  4. Hold down the V-key (Snap to vertices), and dragging along the Y-axis only, snap the pivot to the base of the bounding box.
  5. Hit the Insert or D-key again to exit Pivot mode.
  6. Select the bounding box and delete it.
    Your pivot point should now be aligned at the center of the model and at the very base now.

Centering to the Origin:

  1. Finally, click on the Move tool, hold down the X-key (Snap to Grids) and snap the model to the center of the grid. If the grid is not visible go to Display -> Grid to ensure you are snapping to the origin. 
  2. Once your model is centered at the origin, be sure to Freeze the Transforms.

 

Cinema4D

  1. Select your objects and group them under a Null object.
  2. Select the Null object in the Object Manager.
  3. Go to your Mesh -> Axis Center -> Axis Center… option to bring up the Axis Center dialog.
    AxisCenter_Menu.jpg
  4. Click on the Enable Axis Manipulation button on the left of the CINEMA 4D viewports or by hitting the L-key so you can edit the position of the pivot for the Null object.
    EnableAxisButton.jpg
  5. Set the Action to Axis To, the Center to All Points, and make sure both the Include Children and Use All Objects checkboxes are active.
  6. Next, make sure that Alignment is active and the Axis is set to Y. In the center dialog, make sure the Y position is set to -100% (which will set the Null to the base of the model)
  7. Hit Execute.
    AxisCenter_Dialog2.jpg
    This combo will center the Null’s pivot to the exact center of the model on X and Z and will place it at the base of the model in the Y-axis. All that’s left is to center the model to the Origin.
  8. Deactivate the Enable Axis Manipulation tool (L-key shortcut), so that you can move the entire model.
  9. Zero out your X, Y and Z Position values.
    At this point, your model will be safely centered at the origin.

 

Lightwave

In the Lightwave Modeler, you’re going to want to select all of your objects, then center them. That’s a pretty easy process.

  1. First, press the W-key on your keyboard to bring up the Statistics dialog
  2. Next, hit the Space Bar until you see Polygon Statistics at the top of this dialog.
  3. Press the + sign to the left of the word Total to select all of the Polygons in your scene file, then close the Polygon Statistics panel
    LW_PolyStats_Dialog2.jpg
  4. Finally, press the F3-key to bring up the Rest on Ground dialog. 
  5. Make sure the Rest Axis is set to Y, and all Center Axes are checked as shown below, then hit OK. This will effectively center all of your geometry at the origin and cause the model to sit on the ground plane. 
    LW_RestOnGround_Dialog.jpg

 

Blender

  1. Select your objects and group them under a Null object.
    centering_at_origin_1-e1492714334600.png
  2. Right click to place the 3D cursor where you would like the models new center to be.
    centering_at_origin_2-e1492714378880.png
  3. Then press Shift + Ctrl + Alt + C and click Set Origin to 3D Cursor.
    centering_at_origin_3-e1492714449599.png
  4. Then go to the transforms panel and right click one of the transform values and click Reset All to default Value.
    centering_at_origin_4.png
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.